System requirements. OS: Windows XP and above / Mac OS X 10.6 and above. Processor: 1.6Ghz. Memory: 1GB. Video Card: 128MB and compatible with OpenGL 2.0. Note for Linux users: The game should run in any modern distro but we have only tested with Ubuntu. You are invited to try the teaser, but bear in mind you might have to download additional libraries.

RSS | BLOG